Why Do Some USB-C Hubs Require Drivers to Get Installed?

  • USB-C hubs are typically plug-and-play devices. You connect them to your computer or other device and they work without having to load any special software or device drivers.

    The exceptions are:

    1) The computer's network card driver is missing or outdated.
    2) There are compatibility issues between the computer's driver and the product's network card.
    3) Due to system issues on the computer, updating the network port driver may be necessary to restore normal network speed.

  • @Mokin Global OK, so where's the driver for the UC6001?! I just bought one and neither the ethernet port, nor USB C to HDMI work. 

  • Hi @Dean Hamack

    Thank you for taking the time to contact us.

    Please provide the laptop model.

    Looking forward to your reply!

    Best regards

  • Macbook Pro 2019 Intel, OS 14.4.1

  • Hi @Dean Hamack 

    To pinpoint the problem as quickly as possible, could the following test be tried?

    For ethernet port can't work :

    1) Please confirm that the network is unobstructed and the network cable is good;
    2)Suggest you can unplug the network cable and plug it back in, or replace another cable and plug it back into the product to see if it works?
    3)Meanwhile, in case of connecting more devices, you must connect the charger to the PD port of the product for power supply, otherwise the network port may also fail.

    4)Also, please check if there is a new local connection in the network and Internet settings. If there is then the network port is recognized normally. You may need to consider whether the network cable and the network itself are unobstructed. It is recommended to find a C-port phone or tablet to connect to the hub and plug in the network cable to see if it works. If it works, there is nothing wrong with the product and there may be a problem with your computer or computer settings.
    In the meantime, you can observe how the light of the network port lights up. Whether the green light is on or the orange light is flashing.

    Looking forward to your reply!

  • @Mokin Global

    1. I was able to get the ethernet port working somehow, but I am only getting 40mbps as opposed to the 900+ I get with my Uni ethernet adapter using the same cable.

    2. If I didn't have a USB port, how would I connect the device? The HDMI port has always worked fine. But it will only output 1080p, not the native resolution of my monitor which is 2560. And I need to run 2 monitors. If I plug my USB C to HDMI cable into my Mac it works fine. But when I plug it into the Mokin, it doesn't work. So how am I supposed to run two monitors with your device?

    3. The USB 2 port doesn't work. I plugged a multi-port USB hub into it and the hard drive doesn't show up. Most people need more than one regular USB port, especicially since your device only has one.

    PS - I am running power to the Mokin

  • @Dean Hamack This product can only be connected to one external display, and the C port does not support video transmission.

  • Hi @Dean Hamack,
    Regarding the three points you mentioned, here are some additional explanations:

    1:Regarding the issue with the Ethernet port speed, the suggested solution is as follows:
    Please check if the network chip is 88179. We can provide you with the driver for 88179 for direct installation.
    The download link is:

    Alternatively, you can try the simplest method, which is to uninstall the network card from the Device Manager and then reinstall the driver using Driver Genius or similar software.

    2:Regarding the problem of the computer not recognizing the hard drive, the suggested solution is as follows:

    First, you need to confirm the format of the hard drive. If it is in the NTFS format, it may not be recognized.
    If you have confirmed that this is the issue, the next step is to connect the hard drive to another Windows computer and change the format.
    I hope this helps! If you have any further questions, feel free to ask.


Please login to reply this topic!